PHP Startup: Unable to load dynamic library memcached
Von Huskynarr

Kleine Randnotiz für mein Plesk Problem mit der Libary memcached. Memchached lässt sich nicht installieren.
Bei den Cronjobs etc. erhalte ich die folgende Fehlermeldung:
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/plesk/php/8.1/lib/php/modules/memcached.so' (tried: /opt/plesk/php/8.1/lib/php/modules/memcached.so (/opt/plesk/php/8.1/lib/php/modules/memcached.so: cannot open shared object file: No such file or directory), /opt/plesk/php/8.1/lib/php/modules//opt/plesk/php/8.1/lib/php/modules/memcached.so.so (/opt/plesk/php/8.1/lib/php/modules//opt/plesk/php/8.1/lib/php/modules/memcached.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0Klar lässt sich schnell installieren mit:
/opt/plesk/php/8.1/bin/pecl install memcached
...
checking for libmemcached location… configure: error: memcached support requires libmemcached. Use --with-libmemcached-dir=
to specify the prefix where libmemcached headers and library are located ERROR: `/tmp/memcached/configure --with-php-config=/opt/plesk/php/8.1/bin/php-config --with-libmemcached-dir=no --with-zlib-dir=no --with-system-fastlz=no --enable-memcached-igbinary=no --enable-memcached-msgpack=no --enable-memcached-json=no --enable-memcached-protocol=no --enable-memcached-sasl=yes --enable-memcached-session=yes' failed
Es funktioniert nicht aus einem einfachen Grund, die Dev Requirements fehlen.apt install -y libmemcached-dev zlib1g-dev libssl-devDanach die Installation starten und es funktioniert Problemlos.