WBB 2.1 Lite (Untouched) Download

WBB 2.1 Lite (Untouched) Download

WBB 2.1 Lite wird nicht mehr weiterentwickelt, leider auch nicht mehr das 3er. Ich übernehme dafür also keine Haftung.

Nach langer Suche nach dem WBB 2.1 Lite Paket, fand ich auf meinem eigenen Server noch in einem kaputten Forum die originale Datei.
Untouched steht für Unberührt, also wirklich so wie sie vom Anbieter damals kam.
Leider hat der Anbieter diese gelöscht.

Dennoch hier der Download.

Sollte es Komplikationen mit PHP 5.5 und höher geben, kann es an Deprecated (zu dt. Veralteten) Funktionen liegen.
Dazu muss man dann einfach die Datei „wcf/lib/core.functions.php“ bearbeiten.
In Zeile ~13 muss man einfach:

set_error_handler(array('WCF', 'handleError'), E_ALL);

in das hier ändern:

set_error_handler(array('WCF', 'handleError'), E_ALL & ~E_DEPRECATED); 

Somit ignoriert wbb einfach diverse Möglichkeiten, daher kann es in WBB auch zu Fehlern kommen die unvermeidbar sind.
Quelle: PHP 5.5 Kombatibilität

Übrigens ist es nicht mehr nutzbar ab PHP 5.5, doch es gibt einen hier einen Trick.

Dennoch empfehle ich den schnellstmöglichen Umstieg auf eine aktuellere Version.